Skip to Content.
Sympa Menu

metadata-support - Re: [Metadata-Support] Did something happen Friday, Sept 15 3-5pm?

Subject: InCommon metadata support

List archive

Re: [Metadata-Support] Did something happen Friday, Sept 15 3-5pm?

Chronological Thread 
  • From: Patrick Krogel <>
  • To:
  • Subject: Re: [Metadata-Support] Did something happen Friday, Sept 15 3-5pm?
  • Date: Fri, 22 Sep 2017 11:46:16 -0400
  • Ironport-phdr: 9a23:JJkOmh/i2478vv9uRHKM819IXTAuvvDOBiVQ1KB31escTK2v8tzYMVDF4r011RmSDNWds6oMotGVmpioYXYH75eFvSJKW713fDhBt/8rmRc9CtWOE0zxIa2iRSU7GMNfSA0tpCnjYgBaF8nkelLdvGC54yIMFRXjLwp1Ifn+FpLPg8it2e2//57ebx9UiDahfLh/MAi4oQLNu8cMnIBsMLwxyhzHontJf+RZ22ZlLk+Nkhj/+8m94odt/zxftPw9+cFAV776f7kjQrxDEDsmKWE169b1uhTFUACC+2ETUmQSkhpPHgjF8BT3VYr/vyfmquZw3jSRMMvrRr42RDui9b9mRx3miCkHOTA383zZhNJsg69Auh2tuwZyzpTIbI2JNvdzeL7Wc9MARWpGW8ZcTzZPDZmgb4sVDuoOIeVYpJT4qVsUqhu+ChejBOfywTJPnn/5w6460/4mEQHJwgMgG8kDsHHIrNXoLqsdT/26zLTRwDjFcvhY1zD96I3SfRAgp/GBRbdwcdbMyUU1CQzKk0iQpZTgPzOJy+QBqXKX4PR9WuKyk2InqgdxrSSoxscpj4nJgYQVxkrD9SVjz4Y4I8CzRk1jYdO8Dpddtj2WOolzT8MsQGxnozo2x7gJtJKnYCQG1ZEqyALDZ/GGdoWF5wzvWPiMLjp+mXlrYqiwhwyo/kil0uD8Vte70FJNriddl9nDrHEN1xjK5siGTftx4l6t2DmR2wzN9+5IO080la3cK54uxr4/iIAfvljEHi/zgEn2jamWeVs4+uWw9ejqY6nqq52ZOo96iQzxKbgil8mwDOgkLgQCQm2W9vig2LDi+ED0RatGguMrnaXBtZDVP8Ubpqq3Aw9P1YYj7g6yDy+439Qbh3kHK11FdwyDj4XyPlHOPO34Ae2hjFuxjTdn3+rGMaH5ApXRMnjDl6/sfbd760FAzwozyNVf55VSCr0bJ/LzQEDxuMXdDhAnLwy72fvoB89h1owEQG6PGbKZMLvKsV+P/OIvP/KBZIsUuDbmN/gl/ODigWU4mV8bYammw4EXaHamEfR6PUmVe2TjjcocETRCgg1rSeH2gVGLTTcWfGuqR6Um+hk6DomhCILEQMaqmrPS8j28G8hub3xcC1uPWVTycIqJX79YcC+ROMhunzgsUKS8DYItyEf950fB17N7I7+MqWUjvpX52Y0t6g==

That might have been possible from one of the SPs, but another one of the SPs did not get added until long after we switched, thus never received the old metadata with the :443.

On Fri, Sep 22, 2017 at 11:42 AM, Shannon Roddy <> wrote:

On 9/21/17 1:43 PM, Patrick Krogel wrote:
> I wasn't trying to fix my IdP's metadata.  I hadn't heard about the
> entityID mismatch until days later.  I was going off the assumption that
> the InCommon SP data had gotten corrupted.  I had tried stopping and
> restarting our IdP, but it had no effect.  The next thing I came up with
> was downloading a new copy of the InCommon SP metadata and restarting
> the server again.
> I suppose I was suggesting that maybe InCommon had accidentally
> published our old entityID with the :443 in it.  The Federated SPs would
> then be expecting the :443 in the entityID, but we were responding
> without it.  The entityID could have been fixed and re-published, just
> happening to correspond to the time I made my change and restarted our IdP.

Hi Patrick,

I went through the archive of the published metadata, and the history of
the entityID, and it looks like it wouldn't have been possible that the
:443 entityID was published.  When the entityID was initially created
(Feb 14th, 2017), it was previously rejected with the :443 on the 13th,
and then approved once the port was removed.  So, from the date of
initial publishing it would have been of the form

> The odd thing is that it was just the Federated SPs that were affected. 

Do you have access to any of the SP logs?  Is it possible the SP
reporting the :443 was unable to retrieve the published metadata on the
15th, and then fell back to some local/stale metadata?


> If we were really giving out the wrong entityID, then the other SPs
> should also have been affected.
> On Thu, Sep 21, 2017 at 11:47 AM, Cantor, Scott <
> <mailto:>> wrote:
>     On 9/21/17, 8:42 AM, "
>     <mailto:> on behalf of
>      <mailto:>"
>     <
>     <mailto:> on behalf of
>      <mailto:>> wrote:
>     > I ended up downloading a new InCommon metadata file and restarting our IdP
>     > (since just restarting didn't change anything.)  That was around 5pm and
>     > appeared to fix it.  I was just wondering if I had actually fixed it, or it
>     > was just a coincidence that it started working again.
>     As a matter of simple functional explanation, you cannot correct a
>     problem that may exist in your IdP's metadata by changing the
>     metadata your idP uses. Your IdP doesn't consume its own metadata.
>     If the problem was in an SP's metadata, then obviously reloading it
>     and changing the metadata the IdP uses is a very different matter.
>     What seems more likely is that your system broke in some way and
>     restarting it corrected that.
>     -- Scott
> --
> Patrick Krogel
> Senior Application Systems Analyst
> Information Technology
> Michigan Technological University
> (906)487-1486
> <>
> <>

Patrick Krogel
Senior Application Systems Analyst
Information Technology
Michigan Technological University

Archive powered by MHonArc 2.6.19.

Top of Page